aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-01 00:12:32 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-01 00:17:55 +0100
commitc9b9ef0a19fb036d837547fadac1fa698cee9f91 (patch)
tree2363915c5c55819146d7f08c58b4b7de265d7f6c /gnu/packages/scheme.scm
parentcf822f4d921265ae144ea498b47801d83c1c8bc4 (diff)
downloadguix-c9b9ef0a19fb036d837547fadac1fa698cee9f91.tar
guix-c9b9ef0a19fb036d837547fadac1fa698cee9f91.tar.gz
gnu: Chibi-Scheme: Do not use unstable tarball.
* gnu/packages/scheme.scm (chibi-scheme)[source]: Change to GIT-FETCH.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 349dfe56de..cc69c54703 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -591,14 +591,15 @@ mixed.")
(package
(name "chibi-scheme")
(version "0.8")
+ (home-page "https://github.com/ashinn/chibi-scheme")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/ashinn/chibi-scheme/archive/"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0mi73543m1gap3bwvivq77vhqk7yn28v6g947h96q893n5cph1wa"))
- (file-name (string-append "chibi-scheme-" version ".tar.gz"))))
+ (base32
+ "0269d5fhaz7nqjb41vh7yz63mp5s4z08fn4sspwc06z32xksigw9"))))
(build-system gnu-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -610,7 +611,6 @@ mixed.")
(list (string-append "PREFIX=" out)
(string-append "LDFLAGS=-Wl,-rpath=" out "/lib")))
#:test-target "test"))
- (home-page "https://github.com/ashinn/chibi-scheme")
(synopsis "Small embeddable Scheme implementation")
(description
"Chibi-Scheme is a very small library with no external dependencies