aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-17 19:55:51 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:56:20 +0200
commit1151cd6cf04478ba515519a492069fa781e6e363 (patch)
treedf302063b4874a4be306b3ad8aabed73be30e4fe /gnu/packages/rust.scm
parent3a076fc06e146c088708046d92d6f07296207939 (diff)
downloadguix-1151cd6cf04478ba515519a492069fa781e6e363.tar
guix-1151cd6cf04478ba515519a492069fa781e6e363.tar.gz
gnu: rust-1.55: Build without jemalloc.
* gnu/packages/rust.scm (rust-1.55)[arguments]: Remove references to jemalloc in custom 'configure phase and set rust to build without jemalloc. [inputs]: Remove jemalloc. Change-Id: I388688111c897b15feb6ccee3374219b82f64169
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm17
1 files changed, 3 insertions, 14 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index df3cb112d1..c2c4ce794b 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -46,7 +46,6 @@
#:use-module (gnu packages flex)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gdb)
- #:use-module (gnu packages jemalloc)
#:use-module (gnu packages libunwind)
#:use-module (gnu packages linux)
#:use-module (gnu packages llvm)
@@ -441,16 +440,7 @@ safety and thread safety guarantees.")
(binutils (assoc-ref inputs "binutils"))
(rustc (assoc-ref inputs "rustc-bootstrap"))
(cargo (assoc-ref inputs "cargo-bootstrap"))
- (llvm (assoc-ref inputs "llvm"))
- (jemalloc (assoc-ref inputs "jemalloc")))
- ;; The compiler is no longer directly built against jemalloc, but
- ;; rather via the jemalloc-sys crate (which vendors the jemalloc
- ;; source). To use jemalloc we must enable linking to it (otherwise
- ;; it would use the system allocator), and set an environment
- ;; variable pointing to the compiled jemalloc.
- (setenv "JEMALLOC_OVERRIDE"
- (search-input-file inputs
- "/lib/libjemalloc_pic.a"))
+ (llvm (assoc-ref inputs "llvm")))
(call-with-output-file "config.toml"
(lambda (port)
(display (string-append "
@@ -467,7 +457,7 @@ prefix = \"" out "\"
sysconfdir = \"etc\"
[rust]
debug=false
-jemalloc=true
+jemalloc=false
default-linker = \"" gcc "/bin/gcc" "\"
channel = \"stable\"
rpath = true
@@ -533,8 +523,7 @@ ar = \"" binutils "/bin/ar" "\"
("cargo-bootstrap" ,rust-bootstrap "cargo")
("which" ,which)))
(inputs
- `(("jemalloc" ,jemalloc)
- ("llvm" ,llvm-13)
+ `(("llvm" ,llvm-13)
("openssl" ,openssl)
("libssh2" ,libssh2) ; For "cargo"
("libcurl" ,curl))) ; For "cargo"