aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-29 11:31:46 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:38 +0200
commita1a2a5c31aa19ccb517388bd231ce8d0b628a900 (patch)
tree082482d56a46e159a4ac5e1ec2141fbf7228335b /gnu/packages/rust-apps.scm
parent57ba62d4b9fbc4469d73f0b9cdecb395a138b396 (diff)
downloadguix-a1a2a5c31aa19ccb517388bd231ce8d0b628a900.tar
guix-a1a2a5c31aa19ccb517388bd231ce8d0b628a900.tar.gz
gnu: zoxide: Update to 0.9.2.
* gnu/packages/rust-apps.scm (zoxide): Update to 0.9.2. [cargo-inputs]: Add rust-color-print-0.3, rust-ouroboros-0.17. Replace rust-askama-0.11 with 0.12, rust-clap-3 with 4, rust-clap-complete-3 with 4, rust-clap-complete-fig-3 with 4, rust-dirs-4 with 5, rust-fastrand-1 with 2, rust-nix-0.24 with 0.26. [cargo-development-inputs]: Replace rust-rstest-0.15 with 0.18, rust-rstest-reuse-0.4 with 0.6. Change-Id: Icfd83e6bc30ce6853308405969bcabd4cd0d4213
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm24
1 files changed, 13 insertions, 11 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 5f84a60800..37ab0c51c2 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2849,35 +2849,37 @@ advanced keybindings, word-level diff highlighting, syntax highlighting for
(define-public zoxide
(package
(name "zoxide")
- (version "0.8.3")
+ (version "0.9.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "zoxide" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0y5v2vgl9f3n0n0w4b3iddbfyxv0hls0vw5406ry0hcvnnjyy2l3"))))
+ (base32 "1dqndbxpnv0g82d52jaszsgh62y9cv9hq8rgypsimgkk9yxhn4rw"))))
(build-system cargo-build-system)
(arguments
(list #:install-source? #f
#:cargo-inputs
`(("rust-anyhow" ,rust-anyhow-1)
- ("rust-askama" ,rust-askama-0.11)
+ ("rust-askama" ,rust-askama-0.12)
("rust-bincode" ,rust-bincode-1)
- ("rust-clap" ,rust-clap-3)
- ("rust-clap-complete" ,rust-clap-complete-3)
- ("rust-clap-complete-fig" ,rust-clap-complete-fig-3)
- ("rust-dirs" ,rust-dirs-4)
+ ("rust-clap" ,rust-clap-4)
+ ("rust-clap-complete" ,rust-clap-complete-4)
+ ("rust-clap-complete-fig" ,rust-clap-complete-fig-4)
+ ("rust-color-print" ,rust-color-print-0.3)
+ ("rust-dirs" ,rust-dirs-5)
("rust-dunce" ,rust-dunce-1)
- ("rust-fastrand" ,rust-fastrand-1)
+ ("rust-fastrand" ,rust-fastrand-2)
("rust-glob" ,rust-glob-0.3)
- ("rust-nix" ,rust-nix-0.24)
+ ("rust-nix" ,rust-nix-0.26)
+ ("rust-ouroboros" ,rust-ouroboros-0.17)
("rust-serde" ,rust-serde-1)
("rust-which" ,rust-which-4))
#:cargo-development-inputs
`(("rust-assert-cmd" ,rust-assert-cmd-2)
- ("rust-rstest" ,rust-rstest-0.15)
- ("rust-rstest-reuse" ,rust-rstest-reuse-0.4)
+ ("rust-rstest" ,rust-rstest-0.18)
+ ("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
("rust-tempfile" ,rust-tempfile-3))))
(home-page "https://github.com/ajeetdsouza/zoxide/")
(synopsis "Fast way to navigate your file system")