aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/rust-apps.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-29 09:09:40 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:35 +0200
commit4064b48eb1b4d87a061b09468175e8280b106812 (patch)
treec37c868fc3bc7bbcc666f2bc18bf3d5f7661f1b2 /gnu/packages/rust-apps.scm
parent86f7cd249bdfb61a0d3d388dd21983aa33e572c9 (diff)
downloadguix-4064b48eb1b4d87a061b09468175e8280b106812.tar
guix-4064b48eb1b4d87a061b09468175e8280b106812.tar.gz
gnu: drill: Update to 0.8.2.
* gnu/packages/rust-apps.scm (drill): Update to 0.8.2. [arguments]: Don't install the sources. [cargo-inputs]: Add rust-hdrhistogram-7, rust-openssl-sys-0.9. Replace rust-colored-1 with 2, rust-rand-0.7 with 0.8, rust-reqwest-0.10 with 0.11, rust-tokio-0.2 with 1. Change-Id: I097230b1d2aa538b52478310fcf3ce51a4a577ee
Diffstat (limited to 'gnu/packages/rust-apps.scm')
-rw-r--r--gnu/packages/rust-apps.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index d41028a2ff..1ee30b1f7f 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -389,31 +389,34 @@ highlighting tool to ease code review from your terminal.")
(define-public drill
(package
(name "drill")
- (version "0.7.1")
+ (version "0.8.2")
(source
(origin
(method url-fetch)
(uri (crate-uri "drill" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1m73d7rzi0p5c1hn0081d2235kcyapdza7h0vqf5jhnirpnjn793"))))
+ (base32 "0jp9r19zc9m3hgxc7a98fhyi1ga0qwjprxjsqaxiykmjpb86bxf3"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs
+ `(#:install-source? #f
+ #:cargo-inputs
(("rust-async-trait" ,rust-async-trait-0.1)
("rust-clap" ,rust-clap-2)
- ("rust-colored" ,rust-colored-1)
+ ("rust-colored" ,rust-colored-2)
("rust-csv" ,rust-csv-1)
("rust-futures" ,rust-futures-0.3)
+ ("rust-hdrhistogram" ,rust-hdrhistogram-7)
("rust-lazy-static" ,rust-lazy-static-1)
("rust-linked-hash-map" ,rust-linked-hash-map-0.5)
("rust-num-cpus" ,rust-num-cpus-1)
- ("rust-rand" ,rust-rand-0.7)
+ ("rust-openssl-sys" ,rust-openssl-sys-0.9)
+ ("rust-rand" ,rust-rand-0.8)
("rust-regex" ,rust-regex-1)
- ("rust-reqwest" ,rust-reqwest-0.10)
+ ("rust-reqwest" ,rust-reqwest-0.11)
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
- ("rust-tokio" ,rust-tokio-0.2)
+ ("rust-tokio" ,rust-tokio-1)
("rust-url" ,rust-url-2)
("rust-yaml-rust" ,rust-yaml-rust-0.4))))
(native-inputs
@@ -423,7 +426,7 @@ highlighting tool to ease code review from your terminal.")
(home-page "https://github.com/fcsonline/drill")
(synopsis "HTTP load testing application")
(description
- "Drill is a HTTP load testing application written in Rust inspired by
+ "Drill is a HTTP load testing application written in Rust inspired by
Ansible syntax. Benchmark files can be written in YAML.")
(license license:gpl3)))