aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-14 22:36:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-07-17 23:01:32 -0400
commit12ed6da4fe4dc014c230ebbc857cfc698347ea2f (patch)
treefe55676cfc9039b638be44ac128a6e3781f57f6a /gnu/packages/ruby.scm
parentb6f2a8d164420213c9db223cf818626c8ae1a5ef (diff)
downloadguix-12ed6da4fe4dc014c230ebbc857cfc698347ea2f.tar
guix-12ed6da4fe4dc014c230ebbc857cfc698347ea2f.tar.gz
gnu: Add ruby-test-queue.
* gnu/packages/ruby.scm (ruby-test-queue): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index f80bba9b5f..0fae903592 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6629,6 +6629,38 @@ expressions. It comprises the following components:
(home-page "https://github.com/ammar/regexp_parser")
(license license:expat)))
+(define-public ruby-test-queue
+ (package
+ (name "ruby-test-queue")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "test-queue" version))
+ (sha256
+ (base32
+ "0hvm3n1qrqxqilhqk4rjivw3gcrd08zz1i6am9qzg1ppjxv6f36f"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "rspec"))
+ #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec)))
+ (synopsis "Minitest/RSpec parallel test runner for CI environments")
+ (description "The test-queue module is a parallel test runner,
+built using a centralized queue to ensure optimal distribution of
+tests between workers. It is specifically optimized for Continuous
+Integration (CI) environments: build statistics from each run are
+stored locally and used to sort the queue at the beginning of the next
+run.")
+ (home-page "https://github.com/tmm1/test-queue")
+ (license license:expat)))
+
(define-public ruby-rubocop
(package
(name "ruby-rubocop")