aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-08-06 17:53:43 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:44:02 +0100
commit01035b214079b76867716cd22796ccebc0f3b9d3 (patch)
tree7fa1214129f9028b8cdaae77611eb868b04a6550 /gnu/packages/ruby.scm
parent4e238aa2b0e426b951edc5e0276a37169f4473d7 (diff)
downloadguix-01035b214079b76867716cd22796ccebc0f3b9d3.tar
guix-01035b214079b76867716cd22796ccebc0f3b9d3.tar.gz
gnu: Add ruby-fog-json.
* gnu/packages/ruby.scm (ruby-fog-json): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 88fc3bd23a..ab21bb0403 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9726,6 +9726,29 @@ provides shared classes and tests for @code{fog} providers and services.")
(home-page "https://github.com/fog/fog-core")
(license license:expat)))
+(define-public ruby-fog-json
+ (package
+ (name "ruby-fog-json")
+ (version "1.2.0")
+ (source (origin
+ (method git-fetch) ; for tests
+ (uri (git-reference
+ (url "https://github.com/fog/fog-json")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0f4hbmhy22b1gbkzd3pnj5xvljp6bl7inc2y4fxh29nrmcn4pgb0"))))
+ (build-system ruby-build-system)
+ (native-inputs (list ruby-minitest))
+ (propagated-inputs (list ruby-fog-core ruby-multi-json))
+ (synopsis "JSON parsing tools used by @code{fog} providers")
+ (description "This package containse the JSON parsing tools shared between
+a number of providers in the @code{fog} gem. @code{fog} is a Ruby cloud
+services library.")
+ (home-page "https://github.com/fog/fog-json")
+ (license license:expat)))
+
(define-public ruby-pry-byebug
(package
(name "ruby-pry-byebug")