aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-09-25 15:35:23 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-09-25 15:51:09 +0200
commit1d872a67054291bf05ef00185b60f73d6608bf18 (patch)
tree53d5aac59d3463c7f740d42085d214f320f80df1 /gnu/packages/radio.scm
parent3ac33b9c67919c45942b09cf67e67e8d5be48da3 (diff)
downloadguix-1d872a67054291bf05ef00185b60f73d6608bf18.tar
guix-1d872a67054291bf05ef00185b60f73d6608bf18.tar.gz
gnu: Add satdump.
* gnu/packages/radio.scm (satdump): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 176ea2ac1b..2e4e9db4cc 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2974,6 +2974,47 @@ position fixes) the signals of the BeiDou, Galileo, GLONASS and GPS Global
Navigation Satellite System.")
(license license:gpl3+)))
+(define-public satdump
+ (package
+ (name "satdump")
+ (version "1.1.0")
+ (source
+ ;; TODO: The sources embed some libraries (in src-core/libs).
+ ;; Using regular packaged shared libraries instead will require big
+ ;; changes in CMakeList files.
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SatDump/SatDump")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0mz665h02v4hg0v6kb1b3lj7vd2kp7wgasasm10q6qwqr7c133p4"))))
+ (build-system cmake-build-system)
+ (native-inputs (list pkg-config))
+ (inputs
+ (list airspy
+ airspyhf
+ fftwf
+ glew
+ glfw
+ hackrf
+ libpng
+ luajit
+ nng
+ portaudio
+ rtl-sdr
+ volk
+ (list zstd "lib")))
+ (arguments
+ (list #:tests? #f)) ; No test suite
+ (home-page "https://www.satdump.org/")
+ (synopsis "Satellite data processing software")
+ (description "SatDump is a generic satellite data processing software.
+For example, it can decode the telemetry and images sent by some meteorological
+satellites.")
+ (license license:gpl3)))
+
(define-public qdmr
(package
(name "qdmr")