aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2023-09-30 11:28:06 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2023-10-03 09:50:32 +0200
commit18ee78a9996a97413ed65c1bbb0b0618f9b4ed1d (patch)
tree3d6b65ada58484cef62277d7d18a3b0db5a6bcc1 /gnu/packages/radio.scm
parentee7296ff478fcb79c7d973bff19fa1fc1d78d44e (diff)
downloadguix-18ee78a9996a97413ed65c1bbb0b0618f9b4ed1d.tar
guix-18ee78a9996a97413ed65c1bbb0b0618f9b4ed1d.tar.gz
gnu: Add soapybladerf.
* gnu/packages/radio.scm (soapybladerf): New variable.
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 58e1895799..58b6ca33dc 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -503,6 +503,30 @@ library. It also adds hamlib support, which provides basic gain and frequency
controls for certain tuners which may be paired with an audio device.")
(license license:expat))))
+(define-public soapybladerf
+ (let ((commit "85f6dc554ed4c618304d99395b19c4e1523675b0")
+ (revision "1"))
+ (package
+ (name "soapybladerf")
+ (version (git-version "0.4.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyBladeRF")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "05c5mv1b55jv7dcr740hv4b3gplfaqryflfvprhlkm7bycr8pp16"))))
+ (build-system cmake-build-system)
+ (inputs (list bladerf soapysdr))
+ (arguments (list #:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyBladeRF/wiki")
+ (synopsis "SoapySDR BladeRF module")
+ (description "This package provides BladeRF devices support to the
+SoapySDR library.")
+ (license license:lgpl2.1+))))
+
(define-public soapyhackrf
;; Some fixes are not yet in a tagged release.
(let ((commit "6c0c33f0aa44c3080674e6bca0273184d3e9eb44")