aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-06-13 11:49:15 +0200
committerLudovic Courtès <ludo@gnu.org>2022-06-13 12:27:34 +0200
commit8918ce6d1622303465e716ae491b8e5124c7aece (patch)
tree4ff897378a20cd3a557d72f09e2728f50dc27ae8 /gnu/packages/racket.scm
parent2a2856d5ccd9a9b7df8a94333a277b971a39b150 (diff)
downloadguix-8918ce6d1622303465e716ae491b8e5124c7aece.tar
guix-8918ce6d1622303465e716ae491b8e5124c7aece.tar.gz
gnu: racket: Avoid use of (ice-9 exceptions).
Fixes <https://issues.guix.gnu.org/54546>. Reported by Giovanni Biscuolo <g@xelera.eu> and Michael Chirillo <michael.a.chirillo@gmail.com>. * gnu/packages/racket.scm (racket): Rewrite in terms of SRFI-34/35 instead of (ice-9 exceptions).
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm17
1 files changed, 8 insertions, 9 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index d60a749d91..3399bcc3fe 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013-2016, 2018, 2020-2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2021, 2022 Philip McGrath <philip@philipmcgrath.com>
@@ -28,10 +28,12 @@
#:use-module (guix gexp)
#:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
+ #:use-module (guix diagnostics)
+ #:use-module (guix i18n)
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-26)
+ #:use-module (srfi srfi-34)
#:use-module (ice-9 match)
- #:use-module (ice-9 exceptions)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages bash)
@@ -925,13 +927,10 @@ DrRacket IDE, are not included.")
((this-package-input name)
=> (cut file-append <> "/lib"))
(else
- (raise-exception
- (make-exception
- (make-assertion-failure)
- (make-exception-with-message
- "missing input to the 'racket' package")
- (make-exception-with-irritants
- (list name)))))))
+ (raise
+ (formatted-message
+ (G_ "missing input '~a' to the 'racket' package")
+ name)))))
'("cairo"
"fontconfig-minimal" ;; aka fontconfig
"glib"