aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/racket.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-09 02:02:49 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-12 10:30:08 +0200
commit4c0ac41ba4072677ed5876dacb8e17a7671f20d5 (patch)
tree61afd4e6b3cf0cebacab54b4169e944a1fc11160 /gnu/packages/racket.scm
parent9322697636b4800194154c7153db08eedbba16ce (diff)
downloadguix-4c0ac41ba4072677ed5876dacb8e17a7671f20d5.tar
guix-4c0ac41ba4072677ed5876dacb8e17a7671f20d5.tar.gz
gnu: chez-scheme-for-racket: Fix supported systems.
This commit fixes the treatment of systems like "powerpc-w64-mingw32", where the combination of architecture and kernel is not supported, even though both are supported in other combinations. The build failure fixed in b8fc9169515ef1a6d6037c84e30ad308e5418b6f highlighted this problem: see also <https://issues.guix.gnu.org/54292#6>. The correct support status is specified by '%chez-features-table', which was added to improve 'chez-upstream-features-for-system': this commit uses it to fix the repair. Once the issues in <https://racket.discourse.group/t/950> are resolved, 'chez-scheme-for-racket' and 'racket-vm-cs' will be able to run even on systems for which native code generation is not supported. It's not clear what behavior would be useful from 'nix-system->chez-machine': since the current implementation is flawed and easy to misuse, we remove it for now, replacing the remaining uses with 'racket-cs-native-supported-system?'. * gnu/packages/chez.scm (nix-system->chez-machine): Remove it. (racket-cs-native-supported-system?): New variable. (chez-scheme-for-racket)[supported-systems]: Use it. * gnu/packages/racket.scm (racket-vm-for-system): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/racket.scm')
-rw-r--r--gnu/packages/racket.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/racket.scm b/gnu/packages/racket.scm
index e593f64c21..10617d732c 100644
--- a/gnu/packages/racket.scm
+++ b/gnu/packages/racket.scm
@@ -190,8 +190,11 @@
(define* (racket-vm-for-system #:optional
(system (or (%current-target-system)
(%current-system))))
- "Return 'racket-vm-cs' if it supports SYSTEM; 'racket-vm-bc' otherwise."
- (if (nix-system->chez-machine system)
+ "Return 'racket-vm-cs' if we are able to build it for SYSTEM; 'racket-vm-bc'
+otherwise."
+ ;; Once we figure out the issues in https://racket.discourse.group/t/950,
+ ;; we can use 'racket-vm-cs' everywhere.
+ (if (racket-cs-native-supported-system? system)
racket-vm-cs
racket-vm-bc))