aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-03-13 17:01:55 +0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-04-03 18:05:10 -0400
commitb07346c34b840ea188f05abd62b5b82796f5d88a (patch)
tree4adefcf00c345f240335b8960e72bd7fd9b707c0 /gnu/packages/qt.scm
parented940fb22377bb9ea86dbfefc6fd32a2efa49743 (diff)
downloadguix-b07346c34b840ea188f05abd62b5b82796f5d88a.tar
guix-b07346c34b840ea188f05abd62b5b82796f5d88a.tar.gz
gnu: Add qtspeech.
* gnu/packages/qt.scm (qtspeech): New variable. Change-Id: I99294321514e7e3908d2f25812ceaa76d60bf060 Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 716f16211f..4ca790dfb5 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -2740,6 +2740,50 @@ the end-user is driving and cannot attend the incoming messages on the phone.
In such a scenario, the messaging application can read out the incoming
message.")))
+(define-public qtspeech
+ (package
+ (name "qtspeech")
+ (version "6.6.2")
+ (source (origin
+ (method url-fetch)
+ (uri (qt-url name version))
+ (sha256
+ (base32
+ "1qvf3p2p1pc5fw40d8zq0iawaaqkc0dp5yx85b1dnw1j809bn8y0"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (delete 'check) ;move after the install phase
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check))
+ (add-before 'check 'set-display
+ (lambda _
+ ;; Make Qt render "offscreen", required for tests.
+ (setenv "QT_QPA_PLATFORM" "offscreen")))
+ (add-before 'check 'prepare-for-tests
+ (lambda* (#:key outputs #:allow-other-keys)
+ (setenv "QML2_IMPORT_PATH"
+ (string-append (assoc-ref outputs "out")
+ "/lib/qt6/qml:"
+ (getenv "QML2_IMPORT_PATH")))))
+ (add-after 'install 'delete-installed-tests
+ (lambda _
+ (delete-file-recursively
+ (string-append #$output "/tests")))))))
+ (propagated-inputs (list qtmultimedia))
+ (inputs (list qtbase qtdeclarative))
+ (synopsis "Qt Speech module")
+ (description "The Qt Speech module enables a Qt application to support
+accessibility features such as text-to-speech, which is useful for end-users
+who are visually challenged or cannot access the application for whatever
+reason. The most common use case where text-to-speech comes in handy is when
+the end-user is driving and cannot attend the incoming messages on the phone.
+In such a scenario, the messaging application can read out the incoming
+message.")
+ (home-page (package-home-page qtbase))
+ (license (package-license qtbase))))
+
(define-public qtvirtualkeyboard-5
(package
(inherit qtsvg-5)