aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorChristopher Allan Webber <cwebber@dustycloud.org>2016-06-20 14:05:20 -0500
committerLeo Famulari <leo@famulari.name>2016-08-29 21:44:11 -0400
commitd0b73960db051baa468fc1a0fbab21fa9f89f885 (patch)
treed01ed5fa7c29ac9e4d5191ca6ef76f393a9da29f /gnu/packages/python.scm
parent568230c3787002af8c174838c334e39f0128a2bb (diff)
downloadguix-d0b73960db051baa468fc1a0fbab21fa9f89f885.tar
guix-d0b73960db051baa468fc1a0fbab21fa9f89f885.tar.gz
gnu: python-3.4: Update to 3.4.5.
* gnu/packages/patches/python-disable-ssl-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/python.scm (python-3.4): Update to 3.4.5. [source]: Remove patch. [arguments]: Remove field. (python-minimal)[inputs]: Add libffi.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c34a2495a6..71a20519ec 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -295,21 +295,19 @@ data types.")
(define-public python-3.4
(package (inherit python-2)
- (version "3.4.3")
+ (version "3.4.5")
(source (origin
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (search-patches
"python-fix-tests.patch"
- ;; XXX Try removing this patch for python > 3.4.3
- "python-disable-ssl-test.patch"
"python-3-deterministic-build-info.patch"
"python-3-search-paths.patch"))
(patch-flags '("-p0"))
(sha256
(base32
- "1f4nm4z08sy0kqwisvv95l02crv6dyysdmx44p1mz3bn6csrdcxm"))))
+ "12l9klp778wklxmckhghniy5hklss8r26995pyd00qbllk4b2r7f"))))
(arguments (substitute-keyword-arguments (package-arguments python-2)
((#:tests? _) #t)))
(native-search-paths
@@ -342,14 +340,12 @@ data types.")
(package (inherit python)
(name "python-minimal")
(outputs '("out"))
- (arguments
- (substitute-keyword-arguments (package-arguments python)
- ((#:configure-flags cf)
- `(append ,cf '("--without-system-ffi")))))
+ ;; Build fails due to missing ctypes without libffi.
;; OpenSSL is a mandatory dependency of Python 3.x, for urllib;
;; zlib is required by 'zipimport', used by pip.
- (inputs `(("openssl" ,openssl)
+ (inputs `(("libffi" ,libffi)
+ ("openssl" ,openssl)
("zlib" ,zlib)))))
(define* (wrap-python3 python