aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-23 18:25:16 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-28 15:52:26 +0200
commit81d967075ebe0facc4cbaf6718b89405ea9195d8 (patch)
tree61263d044b6d215d4d2842ea4d3c5963aa9a1941 /gnu/packages/python.scm
parenta1454169e0080d834cbddf94f04c5bcb7c3703e9 (diff)
downloadguix-81d967075ebe0facc4cbaf6718b89405ea9195d8.tar
guix-81d967075ebe0facc4cbaf6718b89405ea9195d8.tar.gz
gnu: python: Rebuild bytecode after removing tests.
* gnu/packages/python.scm (python-3.7)[arguments]: Run 'rebuild-bytecode' after 'remove-tests' to save CPU cycles. Adjust exclude regex.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e39460594b..3d924f7476 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -358,7 +358,7 @@ data types.")
;; FIXME: Without this phase we have close to 400 files that
;; differ across different builds of this package. With this phase
;; there are 44 files left that differ.
- (add-after 'install 'rebuild-bytecode
+ (add-after 'remove-tests 'rebuild-bytecode
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(for-each
@@ -372,8 +372,7 @@ data types.")
"-m" "compileall"
"-f" ; force rebuild
;; Don't build lib2to3, because it's Python 2 code.
- ;; Also don't build obviously broken test code.
- "-x" "(lib2to3|test/bad.*)"
+ "-x" "lib2to3.*"
,file)))
(find-files out "\\.py$")))
(list '() '("-O") '("-OO")))