aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-30 19:06:21 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commitdff3357bb6466f077c9ca575d420a5d2d87ace46 (patch)
treeac2bc40a90e8abc695f388dbcace81b062c59991 /gnu/packages/python-xyz.scm
parentfef6edecbc00b21568effdb923ff0e8e90cdbe50 (diff)
downloadguix-dff3357bb6466f077c9ca575d420a5d2d87ace46.tar
guix-dff3357bb6466f077c9ca575d420a5d2d87ace46.tar.gz
gnu: python-dask: Update to 2024.4.2.
* gnu/packages/python-xyz.scm (python-dask): Update to 2024.4.2. [arguments]: Disable a few tests. Change-Id: I759ddee2ec49fbf74f368c3313f7215906b0e5a2
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ecebbdfb8c..bd99b2fb06 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27954,16 +27954,16 @@ decisions with any given backend.")
(define-public python-dask
(package
(name "python-dask")
- (version "2023.7.0")
+ (version "2024.4.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/dask/dask/")
- (commit "8523b3bae2ec0183d9d92cc536a3405f15189b7e")))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1x617m0jlc63v938kqga9mhflhac3aj1ylq5mkpf2g9pd9x2hcbz"))))
+ (base32 "1kaxlvqd5hknlb0awck5vcw9b18nl8rpxx4j78js8p9d0y5rsgw8"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -27974,6 +27974,14 @@ decisions with any given backend.")
"-k" (string-append
;; This one cannot be interrupted.
"not test_interrupt"
+ ;; This one fails with "local variable 'ctx' referenced
+ ;; before assignment". Maybe enable this in later
+ ;; versions (or when pandas has been upgraded.
+ " and not test_dt_accessor"
+ ;; These all fail with different hashes. Doesn't seem
+ ;; problematic.
+ " and not test_tokenize_local_functions"
+ " and not test_tokenize_functions_unique_token"
;; This one expects a deprecation warning that never
;; comes.
" and not test_RandomState_only_funcs")