aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-07-28 14:24:00 +0200
committerVagrant Cascadian <vagrant@debian.org>2023-08-29 17:12:51 -0700
commitb3cee1c7e86601bae6dbd3beed566ecefa25f626 (patch)
treeda36f735833643e47c3967369f527f306296958b /gnu/packages/python-xyz.scm
parenta012881e158cca32d9e167e8364796b84ff349b0 (diff)
downloadguix-b3cee1c7e86601bae6dbd3beed566ecefa25f626.tar
guix-b3cee1c7e86601bae6dbd3beed566ecefa25f626.tar.gz
gnu: Add python-hjson.
* gnu/packages/python-xyz.scm (python-hjson): New variable. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 385426671e..8df0bb6106 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -140,6 +140,7 @@
;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
;;; Copyright © 2023 Ontje Lünsdorf <ontje.luensdorf@dlr.de>
;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
+;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2167,6 +2168,30 @@ access to HDF5 files, datasets and groups using established Python and NumPy
concepts.")
(license license:bsd-3)))
+(define-public python-hjson
+ ;; Using commit from master branch as the PyPI version does not contain
+ ;; the hjson/tests/ directory.
+ (let ((revision "0")
+ (commit "1687b811fcbbc54b5ac71cfbaa99f805e406fbcb"))
+ (package
+ (name "python-hjson")
+ (version (git-version "3.1.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hjson/hjson-py")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qfqnhvfx5mm7bdajjnnagmvns1zxyksjzh3k5la2ag6a8bp5gki"))))
+ (build-system pyproject-build-system)
+ (home-page "https://github.com/hjson/hjson-py")
+ (synopsis "Python package to parse HJSON documents")
+ (description "This package provides a Python library and a command-line
+interface utility to parse @url{https://hjson.github.io/, HJSON}) documents.")
+ (license license:expat))))
+
(define-public python-hnswlib
(package
(name "python-hnswlib")