aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authornafkhamdc <navid.afkhami@mdc-berlin.de>2024-04-30 14:06:12 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-05-06 10:37:41 +0200
commita5fef66b34623622fdaab87c885f7791b860cb97 (patch)
tree04410f69cd5f09d8f98a21d5f3f29357b0730dc2 /gnu/packages/python-xyz.scm
parentda41a8f5e85774e2a507d821b5d52e600fb9d1d7 (diff)
downloadguix-a5fef66b34623622fdaab87c885f7791b860cb97.tar
guix-a5fef66b34623622fdaab87c885f7791b860cb97.tar.gz
gnu: Add python-archspec.
* gnu/packages/python-xyz.scm (python-archspec): New variable. Change-Id: Icb15a681d7f339ab25cb0a91feeaacc6a3e8cd6a
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 981d915db5..9f3de59bf8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -343,6 +343,57 @@ range of notification services, such as Telegram, Discord, Slack, Amazon SNS,
Gotify, etc.")
(license license:bsd-2)))
+(define-public python-archspec
+ (package
+ (name "python-archspec")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/archspec/archspec")
+ (commit (string-append "v" version))
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03yfn4b9xg41pd7vls2cils77wkkb9si1h2qqvnkds661fdankqj"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ ;; Numba needs a writable dir to cache functions.
+ (add-before 'build 'set-numba-cache-dir
+ (lambda _
+ (setenv "NUMBA_CACHE_DIR" "/tmp"))))))
+ (propagated-inputs (list python-boltons
+ python-cooler
+ python-ctxcore
+ python-interlap
+ python-intervaltree
+ python-jsonschema
+ python-networkx
+ python-numba
+ python-poetry-core
+ pyscenic
+ python-scikit-learn
+ python-tables
+ python-typing-extensions))
+ (native-inputs (list python-black
+ python-flake8
+ python-isort
+ python-poetry-core
+ python-pylint
+ python-pytest
+ python-pytest-cov))
+ (home-page "https://github.com/archspec/archspec")
+ (synopsis "Library to query system architecture")
+ (description
+ "Archspec offers human-readable labels for system architecture aspects.
+These aspects include CPU, network fabrics, etc. In addition, it offers
+APIs to detect, query, and compare them.")
+ (license license:expat)))
+
(define-public python-awkward-cpp
(package
(name "python-awkward-cpp")