aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-18 21:09:24 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:48 +0100
commita14707e3bd2baef83210acbf1f98c6a78c7476a0 (patch)
tree3fbd361dabaf90068bcab57187e99c4df293f9d3 /gnu/packages/python-xyz.scm
parentf6623ccacf439009ad745520ebfc6230b452a70f (diff)
downloadguix-a14707e3bd2baef83210acbf1f98c6a78c7476a0.tar
guix-a14707e3bd2baef83210acbf1f98c6a78c7476a0.tar.gz
gnu: Add python-looseversion.
* gnu/packages/python-xyz.scm (python-looseversion): New variable. Change-Id: I862f10cf5c7285e171335abee429ae76140271dd
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e97c5a269..ce33b330a3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34541,6 +34541,34 @@ needed and registers the function with its annotations.")
symbolic expressions in pure Python using the technique of logical unification.")
(license license:bsd-3)))
+(define-public python-looseversion
+ (package
+ (name "python-looseversion")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "looseversion" version))
+ (sha256
+ (base32 "17k625ws83lwksa7yyy4mn0i39lmxgrzxihn22l335dvyvrnbppb"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; No tests provided.
+ #:tests? #f))
+ (native-inputs
+ (list python-hatchling))
+ (home-page "https://github.com/effigies/looseversion")
+ (synopsis "Version numbering for anarchists and software realists")
+ (description
+ "This package provides a drop-in replacement for the original
+@code{LooseVersion}. It implements an identical interface and comparison
+logic to @code{LooseVersion}. The only major change is that a
+@code{looseversion.LooseVersion} is comparable to a
+@code{distutils.version.LooseVersion}, which means tools should not need to
+worry whether all dependencies that use LooseVersion have migrated.")
+ (license license:psfl)))
+
(define-public python-cons
(package
(name "python-cons")