aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-10-27 15:18:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-10-27 16:13:02 +0200
commit8a7860d9d860b8558558d82d252b12be8e8acadd (patch)
tree5a9190a871fa7b57334b44f5ee651b402b001ff3 /gnu/packages/python-xyz.scm
parenteeb7f8893403066f85d79baae994bfc44d584061 (diff)
downloadguix-8a7860d9d860b8558558d82d252b12be8e8acadd.tar
guix-8a7860d9d860b8558558d82d252b12be8e8acadd.tar.gz
gnu: python-dm-tree: Update to 0.1.8.
* gnu/packages/python-xyz.scm (python-dm-tree): Update to 0.1.8. [build-system]: Use pyproject-build-system. [arguments]: Link with absl_strings_internal and use --whole-archive. Change-Id: I763b01c24082ce1d6a0f4ffd518cfde221b28e72
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b991c448b..fad5d66af9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5819,13 +5819,13 @@ flexibility and power of the Python language.")
(define-public python-dm-tree
(package
(name "python-dm-tree")
- (version "0.1.7")
+ (version "0.1.8")
(source (origin
(method url-fetch)
(uri (pypi-uri "dm-tree" version))
(sha256
- (base32 "0apxfxgmqh22qpk92zmmf3acqkavhwxz78lnwz026a5rlnncizih"))))
- (build-system python-build-system)
+ (base32 "0c4l9gpaqd7j34qwnpjibv53j9sm0nyl0wcy8dvh76772jxspjhg"))))
+ (build-system pyproject-build-system)
(inputs (list pybind11 abseil-cpp python))
(propagated-inputs (list python-wheel
python-absl-py
@@ -5867,13 +5867,16 @@ flexibility and power of the Python language.")
(string-append "-Wl," "-rpath=" python "/lib")
"-fno-semantic-interposition"
"build/temp/tree/tree.o"
+ "-Wl,--whole-archive"
"-L" (string-append python "/lib")
"-L" (string-append abseil-cpp "/lib")
"-l" "absl_int128"
"-l" "absl_raw_hash_set"
"-l" "absl_raw_logging_internal"
"-l" "absl_strings"
+ "-l" "absl_strings_internal"
"-l" "absl_throw_delegate"
+ "-Wl,--no-whole-archive"
"-o" "build/lib/tree/_tree.so")))))))
(home-page "https://github.com/deepmind/tree")
(synopsis "Work with nested data structures in Python")