aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 23:00:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit714baf2295ff850a5aac6d44b5adc9dc6020c45b (patch)
tree413784182901eb9f611d20bc00932035e146f9d0 /gnu/packages/python-xyz.scm
parent31f57ae7dfc239aba2cbbed3bfa87cbcd837bae0 (diff)
downloadguix-714baf2295ff850a5aac6d44b5adc9dc6020c45b.tar
guix-714baf2295ff850a5aac6d44b5adc9dc6020c45b.tar.gz
gnu: python-termcolor: Update to 2.4.0.
* gnu/packages/python-xyz.scm (python-termcolor): Update to 2.4.0. [build-system]: Use pyproject-build-system. [arguments]: Add 'fix-pyproject build phase. [native-inputs]: Add python-hatch-vcs, python-hatchling, python-pytest, and python-pytest-cov. Change-Id: I1b824ca6f125305169c3f64f00dbacbeb77d0ed0
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 16 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b9a7c0b222..e96044d816 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16493,18 +16493,29 @@ a hash value.")
(define-public python-termcolor
(package
(name "python-termcolor")
- (version "1.1.0")
+ (version "2.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "termcolor" version))
(sha256
(base32
- "0fv1vq14rpqwgazxg4981904lfyp84mnammw7y046491cv76jv8x"))))
- (build-system python-build-system)
+ "0ykvmjrsjr5w4h63x7qmx6rsdb1p5a4nv8wgg7nl3b688xhfbfda"))))
+ (build-system pyproject-build-system)
(arguments
- ;; There are no tests.
- `(#:tests? #f))
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'fix-pyproject
+ (lambda _
+ ;; The build system doesn't like to hear of Python 3.13.
+ (substitute* "pyproject.toml"
+ ((" \"Programming Language .*") "")))))))
+ (native-inputs
+ (list python-hatch-vcs
+ python-hatchling
+ python-pytest
+ python-pytest-cov))
(home-page "https://pypi.org/project/termcolor/")
(synopsis "ANSII Color formatting for terminal output")
(description