aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-07-11 23:27:21 +0200
committerjgart <jgart@dismail.de>2024-07-13 09:59:25 -0500
commit61eb25c549886f803c68680fe9293f88d2e2589d (patch)
treec326da917514d22176712719ba61407070b53f2c /gnu/packages/python-xyz.scm
parent987ce3921e6293486084d47b5179af9a2101da81 (diff)
downloadguix-61eb25c549886f803c68680fe9293f88d2e2589d.tar
guix-61eb25c549886f803c68680fe9293f88d2e2589d.tar.gz
gnu: Add python-ailment.
* gnu/packages/python-xyz.scm (python-ailment): New variable. Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d6de1d3d8a..8472c62006 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33791,6 +33791,34 @@ instructions up to AVX-512 and SHA (including 3dnow!+, XOP, FMA3, FMA4, TBM
and BMI2).")
(license license:bsd-2))))
+(define-public python-ailment
+ (package
+ (name "python-ailment")
+ ;; Must be the same version as python-angr.
+ (version "9.2.46")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ailment" version))
+ (sha256
+ (base32 "073fcssbjis1ckwv2w0dcz2dfl6715bj4d4qdhspajj911mvng2f"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ ;; Many tests are skipped due to cyclic dependencies.
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "python" "-m" "unittest"))))))))
+ (home-page "https://github.com/angr/ailment")
+ (synopsis "The angr intermediate language")
+ (description
+ "This Python module implements an @acronym{IL, Intermediate Language},
+also known as @acronym{IR, Intermediate Representation}, used by the angr
+binary analysis platform.")
+ (license license:bsd-2)))
+
(define-public python-cle
(package
(name "python-cle")