aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-02 21:38:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:17 +0200
commit6095e5b43649b3ec47c8f2e7a88124041dd59907 (patch)
tree71df8d6fe3fdbb9df815a7633e931731f0c29fa7 /gnu/packages/python-xyz.scm
parent6244177e793b0e48090973875b23b65967f28504 (diff)
downloadguix-6095e5b43649b3ec47c8f2e7a88124041dd59907.tar
guix-6095e5b43649b3ec47c8f2e7a88124041dd59907.tar.gz
gnu: snakemake-7: Make compatible with tabulate 0.9.0.
* gnu/packages/python-xyz.scm (snakemake-7)[arguments]: Add phase 'tabulate-compatibility. Change-Id: Ie6b2a7d65bc76e3df7c3946ba4533b301f5a3610
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10d920b4b6..7f368d1ebc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13370,6 +13370,12 @@ Python style, together with a fast and comfortable execution environment.")
(string-append
"tibanna_args.command = command.replace('"
#$output "/bin/snakemake', 'python3 -m snakemake')")))))
+ ;; No longer needed with 7.15.2+
+ (add-after 'unpack 'tabulate-compatibility
+ (lambda _
+ (substitute* "snakemake/dag.py"
+ (("\"job\": rule,")
+ "\"job\": rule.name,"))))
(add-after 'unpack 'patch-version
(lambda _
(substitute* "setup.py"