aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-02 15:15:14 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:47 +0100
commit573d478f729d732b65b2dabc295a31e08f9ad32b (patch)
tree15b5ac5d525eef273002ddf92b2c2fe8879d3868 /gnu/packages/python-xyz.scm
parent77d4efec425418d7cb11369cb8b1d59b8b4dfd2b (diff)
downloadguix-573d478f729d732b65b2dabc295a31e08f9ad32b.tar
guix-573d478f729d732b65b2dabc295a31e08f9ad32b.tar.gz
gnu: Add python-dunamai.
* gnu/packages/python-xyz.scm (python-dunamai): New variable. Change-Id: Iabb0221c615ee345d1e557d2d428254929823283
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8d8c082a5f..9f1282867c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23442,6 +23442,47 @@ system.")
;; Can be used with either license.
(license (list license:asl2.0 license:gpl2+))))
+(define-public python-dunamai
+ (package
+ (name "python-dunamai")
+ (version "1.21.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "dunamai" version))
+ (sha256
+ (base32 "1i35i8ym6n8mpgrq31hivrvfciy12gv26jwlzimmkx9jy2spz0h5"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" "not test__version__from_git__shallow")
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; These steps are taked from NixOS package definition:
+ ;; nixpkgs/pkgs/development/python-modules/dunamai/default.nix
+ (add-before 'check 'pre-check
+ (lambda _
+ (setenv "PATH" (string-append #$output "/bin:" (getenv "PATH")))
+ (setenv "HOME" "/tmp")
+ (invoke "git" "config" "--global" "user.email" "nobody@example.com")
+ (invoke "git" "config" "--global" "user.name" "Nobody"))))))
+ (propagated-inputs
+ (list python-packaging))
+ (native-inputs
+ (list git-minimal
+ python-poetry-core
+ python-pytest))
+ (home-page "https://github.com/mtkennerly/dunamai")
+ (synopsis "Dynamic version generation")
+ (description
+ "Dunamai is Python library and command line tool for producing dynamic,
+standards-compliant version strings, derived from tags in your version control
+system. This facilitates uniquely identifying nightly or per-commit builds in
+continuous integration and releasing new versions of your software simply by
+creating a tag.")
+ (license license:expat)))
+
(define-public python-pbkdf2
(package
(name "python-pbkdf2")