aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-04-16 20:58:06 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-16 20:58:06 -0400
commit2d5736cc3e869fadd2592cc13a8d332fac63b144 (patch)
tree3ff2045099afb796eaa294e693ce4708e2021af9 /gnu/packages/python-xyz.scm
parentdbfb691c5b4bc66682657ebf124815f5b93fcdbd (diff)
parent953253eff32197863d223e5fece42b3c2440df01 (diff)
downloadguix-2d5736cc3e869fadd2592cc13a8d332fac63b144.tar
guix-2d5736cc3e869fadd2592cc13a8d332fac63b144.tar.gz
Merge branch 'mesa-updates'
Key updates: cairo 1.16.0 -> 1.18.0 libdrm 2.4.117 -> 2.4.120 mesa 23.3.2 -> 24.0.3 sdl2 2.28.5 -> 2.30.1 vulkan packages 1.3.231.1 -> 1.3.280.0 openexr 3.1.3 -> 3.2.4 Change-Id: Iece081158251d1d5836f6b264ba232dc751c9fe2
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 6 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 44c709a880..bac90b1e07 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10738,7 +10738,7 @@ support for Python 3 and PyPy. It is based on cffi.")
(define-public python-cairocffi
(package
(name "python-cairocffi")
- (version "1.3.0")
+ (version "1.6.1")
(source
(origin
;; The PyPI archive does not include the documentation, so use Git.
@@ -10749,13 +10749,15 @@ support for Python 3 and PyPy. It is based on cffi.")
(file-name (git-file-name name version))
(sha256
(base32
- "0lylyxyyd8csjhn5kxwzrcr6ick6pvvm1wclpmb5ni28jznxn7lb"))))
- (build-system python-build-system)
+ "161z2bsp0ai4311mz9n0h6vmz80690jbijxx2gqkknygwm2ynjgd"))))
+ (build-system pyproject-build-system)
(outputs '("out" "doc"))
(inputs
(list glib gtk+ gdk-pixbuf cairo))
(native-inputs
- (list python-numpy
+ (list python-flit-core
+ python-numpy
+ python-pikepdf
python-pytest
python-pytest-cov
python-pytest-runner
@@ -10785,15 +10787,6 @@ support for Python 3 and PyPy. It is based on cffi.")
(search-input-file inputs "/lib/libglib-2.0.so.0"))
(("libgdk-3.so.0")
(search-input-file inputs "/lib/libgdk-3.so.0")))))
- (add-after 'unpack 'disable-linters
- ;; Their check fails; none of our business.
- (lambda _
- (substitute* "setup.cfg"
- ((".*pytest-flake8.*") "")
- ((".*pytest-isort.*") "")
- (("--flake8") "")
- (("--isort") ""))
- #t))
(add-after 'install 'install-doc
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((data (string-append (assoc-ref outputs "doc") "/share"))