aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-10-20 00:49:25 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-26 11:11:37 +0100
commit2d08212d473a490eb0d84fa3e3c9c1ed5d897d95 (patch)
tree533d49a28419d5c6fe459b80f365f0626352640b /gnu/packages/python-xyz.scm
parenta563b38401309d709b2915d8341305f9997becdc (diff)
downloadguix-2d08212d473a490eb0d84fa3e3c9c1ed5d897d95.tar
guix-2d08212d473a490eb0d84fa3e3c9c1ed5d897d95.tar.gz
gnu: Add python-asyncstdlib.
* gnu/packages/python-xyz.scm (python-asyncstdlib): New variable. Change-Id: I2554c120e070b0c84a7228a20cfa22abfd84c846 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b58eb1ff88..0068c3fed9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -404,6 +404,30 @@ These aspects include CPU, network fabrics, etc. In addition, it offers
APIs to detect, query, and compare them.")
(license license:expat)))
+(define-public python-asyncstdlib
+ (package
+ (name "python-asyncstdlib")
+ (version "3.12.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "asyncstdlib" version))
+ (sha256
+ (base32 "1nr7rhfcqyzhv8lnj2rpgg60sw795xqp11a58dky8nfbd9gh5c3y"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core python-pytest))
+ (home-page "https://asyncstdlib.readthedocs.io")
+ (synopsis "Compatibility layer between the Python stdlib and @code{async}
+callables")
+ (description
+ "The @code{asyncstdlib} library re-implements functions and classes of
+the Python standard library to make them compatible with @code{async}
+callables, iterables and context managers. It is fully agnostic to
+@code{async} event loops and seamlessly works with @code{asyncio}, third-party
+libraries such as @code{trio}, as well as any custom @code{async} event
+loop.")
+ (license license:expat)))
+
(define-public python-awkward-cpp
(package
(name "python-awkward-cpp")