aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-12-17 12:20:28 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-17 12:23:17 +0000
commit2185b5ad3d252774ae633a90e03d34cc24b95c38 (patch)
treef882dad223dae5e291b591834e9b6c12c0938fec /gnu/packages/python-xyz.scm
parent00bcb384da5c69e96b689f3d01a9ebe46b7b9fd7 (diff)
downloadguix-2185b5ad3d252774ae633a90e03d34cc24b95c38.tar
guix-2185b5ad3d252774ae633a90e03d34cc24b95c38.tar.gz
gnu: python-numcodecs: Fix build.HEADmaster
* gnu/packages/python-xyz.scm (python-numcodecs) [arguments]<test-flags>: Skip 2 failing tests. Change-Id: Ia4c1e8af6063f53a2d3c921931c8d3b3f0674ca7
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0381d8fdc1..41b135586b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29099,6 +29099,7 @@ tool).")
(define-public python-numcodecs
(package
(name "python-numcodecs")
+ ;; XXX: Starting from 0.11.0 numcodecs requires NumPy 1.7 or higher.
(version "0.10.2")
(source
(origin
@@ -29127,6 +29128,12 @@ tool).")
(build-system pyproject-build-system)
(arguments
(list
+ #:test-flags
+ ;; Tests fail with error: ValueError: setting an array element with a
+ ;; sequence. The requested array has an inhomogeneous shape after 1
+ ;; dimensions. The detected shape was (3,) + inhomogeneous part.
+ #~(list "--deselect=numcodecs/tests/test_json.py::test_non_numpy_inputs"
+ "--deselect=numcodecs/tests/test_msgpacks.py::test_non_numpy_inputs")
#:phases
'(modify-phases %standard-phases
(add-after 'unpack 'disable-avx2