aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-13 09:19:13 -0300
committerVinicius Monego <monego@posteo.net>2024-07-14 10:23:53 -0300
commit14737ed048566c5bfc20eee55373e3f81871ec13 (patch)
treef91aaff5a6a7e5629502a02b93d536e5dfcbdd88 /gnu/packages/python-xyz.scm
parent610508cf1bf18be2de05c72db9a1f8a43532ef5c (diff)
downloadguix-14737ed048566c5bfc20eee55373e3f81871ec13.tar
guix-14737ed048566c5bfc20eee55373e3f81871ec13.tar.gz
gnu: python-hy: Update to 0.29.0.
* gnu/packages/python-xyz.scm (python-hy): Update to 0.29.0. [arguments]<#:phases>: Delete the 'set-version and 'remove-installed-build-scripts phases. Hy no longer uses them to report its version. Change-Id: Ie3c388bc8b0c55d275bb00a0ad9eb7d09c37228c
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 983d8d73b6..09b9378bc7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18404,7 +18404,7 @@ with a new public API, and RPython support.")
(define-public python-hy
(package
(name "python-hy")
- (version "0.28.0")
+ (version "0.29.0")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -18413,23 +18413,12 @@ with a new public API, and RPython support.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0fs9ydqlbhmp4l3lf8ap8bksbpmlscm6gz7zf9bv2kmcldkjlzsw"))))
+ (base32 "0fp5x94hyckjfap2pb1rj551a3q70vrljxark7hj9kdhr7prbggi"))))
(build-system python-build-system)
(arguments
(list
#:phases
#~(modify-phases %standard-phases
- ;; Hy includes a script that writes a version.py file that Hy uses to
- ;; report its version. That script uses information from the git
- ;; repository or the HY_VERSION environment variable. Therefore,
- ;; these phases set HY_VERSION and then remove the support scripts
- ;; which get installed in the root of the output.
- (add-after 'unpack 'set-version
- (lambda _
- (setenv "HY_VERSION" #$version)))
- (add-after 'install 'remove-installed-build-scripts
- (lambda _
- (delete-file-recursively (string-append #$output "/get_version"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?