aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSpencer King <spencer@nursiapress.com>2023-11-27 19:44:39 -0600
committerLudovic Courtès <ludo@gnu.org>2023-12-03 23:55:08 +0100
commit1308f0fe0e113f8e94539f0118f817b7bf0f23bf (patch)
tree605ecd58ec6069d2c13e9941dbf85cbbe22a8858 /gnu/packages/python-xyz.scm
parent27c24ce83f53e3453eedf5469560e3c4404ca81b (diff)
downloadguix-1308f0fe0e113f8e94539f0118f817b7bf0f23bf.tar
guix-1308f0fe0e113f8e94539f0118f817b7bf0f23bf.tar.gz
gnu: Add python-islenska.
* gnu/packages/python-xyz.scm (python-islenska): New variable. Change-Id: Id9acd04d625bbbdef0438b1b98b73550e826088d Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ce4f2f76ee..f87e6fc3f7 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34220,6 +34220,28 @@ software by taking care of all interactions with low-level network programming
interfaces.")
(license license:gpl2)))
+(define-public python-islenska
+ (package
+ (name "python-islenska")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "islenska" version))
+ (sha256
+ (base32 "0fdp90mzy0sd4kyw8kd8kybd1ni765fvqn8hz2wx5sqbjjkm4d5k"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-cffi python-typing-extensions))
+ (home-page "https://github.com/mideind/BinPackage")
+ (synopsis
+ "Vocabulary of the modern Icelandic language, in a Python package")
+ (description
+ "Islenska is a Python package that embeds the vocabulary of the Database
+of Icelandic Morphology and offers various lookups and queries of the data.
+The database contains over 6.5 million entries, over 3.1 million unique word
+forms, and about 300,000 distinct lemmas.")
+ (license license:expat)))
+
(define-public python-zeroc-ice-3.6
(package
(inherit python-zeroc-ice)