aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-07-07 18:04:24 +0000
committerLudovic Courtès <ludo@gnu.org>2024-07-18 17:31:19 +0200
commit0514502408a480d6b15b878cf7f2c1fcfc927e2c (patch)
tree2aaf7bc3061b07ce0ddc810deb9de07746e114ce /gnu/packages/python-xyz.scm
parente0cb8cb6e1cde40cfb7cf40fcf5c0a775e5301b4 (diff)
downloadguix-0514502408a480d6b15b878cf7f2c1fcfc927e2c.tar
guix-0514502408a480d6b15b878cf7f2c1fcfc927e2c.tar.gz
gnu: Add python-xmp-toolkit.
* gnu/packages/python-xyz.scm (python-xmp-toolkit): New variable. * gnu/packages/patches/python-xmp-toolkit-add-missing-error-codes.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Change-Id: Ibce05155961eb5ba199754646e08acff2410f95d Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 747af90978..fcf01f3d04 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -37502,6 +37502,48 @@ write text fast, and for various text generation, statistics, and modeling tasks
(base32
"0mikjfvq26kh8asnn9v55z41pap4c5ypymqnwwi4xkavc3mzyda2"))))))
+(define-public python-xmp-toolkit
+ (package
+ (name "python-xmp-toolkit")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-xmp-toolkit" version))
+ (sha256
+ (base32 "12x6lyaxjpbl8ll3cj97039kwvsha2nkx2v8v8irfbi2p0dl721s"))
+ (patches (search-patches
+ "python-xmp-toolkit-add-missing-error-codes.patch"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" (string-append "not test_can_put_xmp and "
+ "not test_exempi_bad_combinations and "
+ "not test_formats and "
+ "not test_get_xmp and "
+ "not test_open_file_with_options"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'configure-environment
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((exempi #$(this-package-input "exempi")))
+ (setenv "LD_LIBRARY_PATH"
+ (string-append exempi "/lib"))))))))
+ (inputs (list exempi))
+ (propagated-inputs (list python-pytz))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/python-xmp-toolkit/python-xmp-toolkit")
+ (synopsis "Python XMP Toolkit for working with metadata.")
+ (description "Python XMP Toolkit is a library for working with XMP
+metadata, as well as reading/writing XMP metadata stored in many different
+file formats.
+
+Python XMP Toolkit is wrapping Exempi (using ctypes), a C/C++ XMP library
+based on Adobe XMP Toolkit, ensuring that future updates to the XMP standard
+are easily incorporated into the library with a minimum amount of work.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar