aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
authorSören Tempel <soeren@soeren-tempel.net>2024-07-11 23:27:13 +0200
committerjgart <jgart@dismail.de>2024-07-13 09:59:17 -0500
commit0114007bf3e548d7bc1e22adafc89799f8255da9 (patch)
treef38eea805e206866a426d1ba0c565774241b3673 /gnu/packages/python-xyz.scm
parent13369ba7cae78742e261ff0b79e149b8db37c554 (diff)
downloadguix-0114007bf3e548d7bc1e22adafc89799f8255da9.tar
guix-0114007bf3e548d7bc1e22adafc89799f8255da9.tar.gz
gnu: Add python-mulpyplexer.
* gnu/packages/python-xyz.scm (python-mulpyplexer): New variable. Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1bf07d3c26..0ad45c6c70 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -33790,6 +33790,29 @@ instructions up to AVX-512 and SHA (including 3dnow!+, XOP, FMA3, FMA4, TBM
and BMI2).")
(license license:bsd-2))))
+(define-public python-mulpyplexer
+ (package
+ (name "python-mulpyplexer")
+ (version "0.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "mulpyplexer" version))
+ (sha256
+ (base32 "0c5xzci1djy1yi9hxxh8g67l6ms8r7ad7ja20pv8hfbdysdrwkhl"))))
+ (build-system pyproject-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "mulpyplexer.py")))))))
+ (home-page "https://github.com/zardus/mulpyplexer/")
+ (synopsis "Multiplexes interactions with lists of Python objects")
+ (description "This module provides utilities for multiplexing
+interactions with lists of Python objects.")
+ (license license:bsd-2)))
+
(define-public python-itanium-demangler
(package
(name "python-itanium-demangler")