aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2024-07-01 15:56:59 +0000
committerjgart <jgart@dismail.de>2024-07-13 09:05:17 -0500
commitddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3 (patch)
treefb8606df40cfc648c17d0480a15e53c951fc4865 /gnu/packages/python-web.scm
parent2bc4590a0739613ac57d5f82aa2dbdacca74deaa (diff)
downloadguix-ddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3.tar
guix-ddb22a10e04c966eaa6ecbc50c3fc75dc3a143c3.tar.gz
gnu: python-requests-toolbelt: Update to 1.0.0.
* gnu/packages/python-web.scm (python-requests-toolbelt): Update to 1.0.0. [arguments]: Delete tests that are incompatible with urllib3 >= 2.0. [native-inputs]: Remove python-mock; add python-pyopenssl and python-trustme. Change-Id: I349bd9cef34cdbf7a51612e8b9d5dac59101d1bd Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm17
1 files changed, 11 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 177d1015f0..62e92fc9a7 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -49,7 +49,7 @@
;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2022, 2023 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022–2024 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Peter Polidoro <peter@polidoro.io>
;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
@@ -3759,13 +3759,13 @@ portions of your testing code.")
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
- (version "0.9.1")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests-toolbelt" version))
(sha256
(base32
- "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
+ "1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
@@ -3775,9 +3775,14 @@ portions of your testing code.")
(delete-file "tests/test_x509_adapter.py")
;; Fails due to networking (socket.gaierror: [Errno -2]
;; Name or service not known).
- (delete-file "tests/test_multipart_encoder.py"))))))
- (native-inputs
- (list python-betamax python-mock python-pytest))
+ (delete-file "tests/test_multipart_encoder.py")
+ ;; Those tests are not compatible with urllib3 2.0,
+ ;; according to
+ ;; https://github.com/requests/toolbelt/pull/356
+ (delete-file "tests/test_sessions.py")
+ )))))
+ (native-inputs
+ (list python-betamax python-pyopenssl python-pytest python-trustme))
(propagated-inputs
(list python-requests))
(synopsis "Extensions to python-requests")