aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-16 01:51:04 -0500
committerjgart <jgart@dismail.de>2024-07-16 02:02:04 -0500
commitb91353f372dbbccdb98d6407739841a2863067dd (patch)
treef00135553708fa14328e350c8afe49fe5eb726b2 /gnu/packages/python-web.scm
parent07557fd1490ad73b81dd4bebd0f61958f8375966 (diff)
downloadguix-b91353f372dbbccdb98d6407739841a2863067dd.tar
guix-b91353f372dbbccdb98d6407739841a2863067dd.tar.gz
gnu: Add gunicorn-next.
* gnu/packages/python-xyz.scm (gunicorn-next): New variable. Change-Id: I7a89e77bb0fcdfa620d07600bb06c75a720ce9b8
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7f8613e9c4..0515f1c9f1 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6182,6 +6182,21 @@ various web frameworks, simply implemented, light on server resources,
and fairly speedy.")
(license license:expat)))
+(define-public gunicorn-next
+ (package
+ (inherit gunicorn)
+ (name "gunicorn")
+ (version "22.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gunicorn" version))
+ (sha256
+ (base32
+ "0qzc3ghayc137hlwrqqwkkhaf8f5h9ja21qwy4rznxpz75i462sa"))))
+ ;; CVE-2024-1135 is fixed in version 22.0.0.
+ (properties `((lint-hidden-cve . ("CVE-2024-1135"))))))
+
;; break cyclic dependency for python-aiohttp, which depends on gunicorn for
;; its tests
(define-public gunicorn-bootstrap