aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-11 22:59:41 +0200
committerMarius Bakke <marius@gnu.org>2022-09-11 23:41:43 +0200
commit752711b880f148ee7aab7a6ab8c3aaccdd8838de (patch)
treeb5458338ac346abcbc64870617450df1ed61ba51 /gnu/packages/python-web.scm
parent9b3124b2fc19e83c516606e84932a449e0b2b8a1 (diff)
downloadguix-752711b880f148ee7aab7a6ab8c3aaccdd8838de.tar
guix-752711b880f148ee7aab7a6ab8c3aaccdd8838de.tar.gz
gnu: python-uvloop: Disable flaky test.
* gnu/packages/python-web.scm (python-uvloop)[arguments]: Disable one more test. While at it, use 'thread' timeout method as signal did not work here. Also don't compute the pytest string at evaluation time.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4234b4bcab..94544e1e74 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4984,12 +4984,17 @@ hard or impossible to fix in cssselect.")
;; The tests are prone to get stuck. Use pytest-timeout’s --timeout
;; flag to get a meaningful idea about where.
(invoke "pytest" "-vv" "--timeout=300"
- "-k" ,(string-append
+ "--timeout-method=thread"
+ "-k" (string-append
;; Timeout, because SIGINT cannot be sent to child.
"not test_signals_sigint_pycode_continue "
"and not test_signals_sigint_pycode_stop "
"and not test_signals_sigint_uvcode "
"and not test_signals_sigint_uvcode_two_loop_runs "
+ ;; This test is racy and prone to get stuck on
+ ;; various platforms, possibly a aiohttp issue:
+ ;; https://github.com/MagicStack/uvloop/issues/412
+ "and not test_remote_shutdown_receives_trailing_data "
;; It looks like pytest is preventing
;; custom stdout/stderr redirection,
;; even with -s.