aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorconses <contact@conses.eu>2022-11-24 00:00:58 +0100
committerChristopher Baines <mail@cbaines.net>2022-11-24 09:44:25 +0000
commit68113dc2498e507879eeecc583a66a5bc046c91b (patch)
treeebe923f57ae8892056057c313ca7f60d9d00e81e /gnu/packages/python-web.scm
parent42898ae8ca25347a4b889bd44203ee7675f0c407 (diff)
downloadguix-68113dc2498e507879eeecc583a66a5bc046c91b.tar
guix-68113dc2498e507879eeecc583a66a5bc046c91b.tar.gz
gnu: Add whoogle-search.
* gnu/packages/python-web.scm (whoogle-search): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 905d79886f..4f3a587c6a 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4743,6 +4743,65 @@ Google search engine. Its module is called @code{googlesearch}.")
(description "Python client library for Google's discovery based APIs")
(license license:asl2.0)))
+(define-public whoogle-search
+ (package
+ (name "whoogle-search")
+ (version "0.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "whoogle-search" version))
+ (sha256
+ (base32
+ "0h8cl9bkd3vx17kbvcnmc8cy6pc29lxr0drxm84kj37ka788cj2g"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ ;; The tests need network access
+ #:tests? #f))
+ (propagated-inputs
+ (list python-attrs
+ python-beautifulsoup4
+ python-cachelib
+ python-certifi
+ python-cffi
+ python-brotli
+ python-chardet
+ python-click
+ python-cryptography
+ python-cssutils
+ python-defusedxml
+ python-flask
+ python-flask-session
+ python-idna
+ python-itsdangerous
+ python-jinja2
+ python-markupsafe
+ python-more-itertools
+ python-packaging
+ python-pluggy
+ python-py
+ python-pycodestyle
+ python-pycparser
+ python-pyopenssl
+ python-pyparsing
+ python-pysocks
+ python-dateutil
+ python-requests
+ python-soupsieve
+ python-stem
+ python-urllib3
+ python-waitress
+ python-wcwidth
+ python-werkzeug
+ python-dotenv))
+ (home-page "https://github.com/benbusby/whoogle-search")
+ (synopsis "Self-hosted, ad-free, privacy-respecting metasearch engine")
+ (description
+ "Get Google results, but without any ads, javascript, AMP links,
+cookies, or IP address tracking. Quick and simple to implement as a primary
+search engine replacement on both desktop and mobile.")
+ (license license:expat)))
+
(define-public python-hawkauthlib
(package
(name "python-hawkauthlib")