aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-15 15:00:52 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-27 22:51:56 +0000
commit63bcebd90e092aed9b5014cff1660d9ac83cbce7 (patch)
treec51224e75ea9791255ed2b0c067c33d09a237f30 /gnu/packages/python-web.scm
parentbcf5143c1fb350e7ffa663e1939b63f0fbcf4ac1 (diff)
downloadguix-63bcebd90e092aed9b5014cff1660d9ac83cbce7.tar
guix-63bcebd90e092aed9b5014cff1660d9ac83cbce7.tar.gz
gnu: parfive: Simplify package.
* gnu/packages/python-web.scm (parfive) [build-system]: Swap to pyproject-build-system. [arguments] <#:phases>: Use standard 'check phase. <#:test-flags>: Move disabled tests here and remove 'disable-test-requiring-network phase. Change-Id: I08b67b2aa7027ac37e0a3df4da7ebb01ea3c451e
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index adae8d7272..de57d5be94 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1326,18 +1326,15 @@ HTTP servers, RESTful APIs, and web services.")
(sha256
(base32
"0pf8rzfwxpkn84xzb4v8m1fy3k7kjlh8f9ln4y5xqlnbqpwi30lh"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- (list #:phases #~(modify-phases %standard-phases
- (add-before 'check 'disable-test-requiring-network
- (lambda _
- (substitute* "parfive/tests/test_downloader.py"
- (("def test_ftp")
- "def __off_test_ftp"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-vvv" "parfive")))))))
+ (list
+ ;; Disable tests requiring network access.
+ #:test-flags
+ #~(list "-k" (string-append
+ "not test_ftp"
+ " and not test_ftp_pasv_command"
+ " and not test_ftp_http"))))
(propagated-inputs (list python-aiofiles python-aioftp python-aiohttp
python-tqdm))
(native-inputs (list python-pytest