aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2022-09-24 18:09:53 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-04 18:15:36 +0200
commit58f6b246a6c3f3cf1cfdcce6bd2cdb3a26c23c9b (patch)
treeb398d10d5578fadc3a222e1fdcf4df7b9fd8172d /gnu/packages/python-web.scm
parentd7932b731f0a3b396c6b2503a461a21a474098c3 (diff)
downloadguix-58f6b246a6c3f3cf1cfdcce6bd2cdb3a26c23c9b.tar
guix-58f6b246a6c3f3cf1cfdcce6bd2cdb3a26c23c9b.tar.gz
gnu: Add awscli-2.
* gnu/packages/python-web.scm (awscli-2): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1f0b43d1ad..6a9d6ee61d 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -57,6 +57,7 @@
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 msimonin <matthieu.simonin@inria.fr>
;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3262,6 +3263,26 @@ supports url redirection and retries, and also gzip and deflate decoding.")
Amazon Web Services (AWS) API.")
(license license:asl2.0)))
+(define-public awscli-2
+ (package
+ (inherit awscli)
+ (name "awscli")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri (string-append name "v2") version))
+ (sha256
+ (base32
+ "0g1icsy2l4n540gnhliypy830dfp08hpfc3rk12dlxgc9v3ra4wl"))))
+ (arguments
+ ;; FIXME: The 'pypi' release does not contain tests.
+ '(#:tests? #f))
+ (inputs
+ (list python-importlib-resources
+ python-executor))))
+
+
(define-public python-wsgiproxy2
(package
(name "python-wsgiproxy2")