aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-16 10:28:05 -0500
committerjgart <jgart@dismail.de>2024-07-16 10:28:05 -0500
commit325fed4c1514bffd084355455710fcc3f1c8da2c (patch)
tree00b76b9a673a1375e6745e90c71b039dd58b6496 /gnu/packages/python-web.scm
parent79b1f401768631234022b3344e7726e60cb3e73c (diff)
downloadguix-325fed4c1514bffd084355455710fcc3f1c8da2c.tar
guix-325fed4c1514bffd084355455710fcc3f1c8da2c.tar.gz
gnu: python-pyowm: Update to 3.3.0.
* gnu/packages/python-web.scm (python-pyowm): Update to 3.3.0. [build-system]: Use pyproject build system. [arguments]: Run unit tests. [native-inputs]: Add python-pytest. [propagated-inputs]: Add python-geojson-for-pyowm. Change-Id: Ifde514f971cf3821905d9f1beb491a53e7799325
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 0515f1c9f1..ae63d58131 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6997,15 +6997,24 @@ changed the process is restarted.")
(define-public python-pyowm
(package
(name "python-pyowm")
- (version "3.2.0")
+ (version "3.3.0")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "pyowm" version))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/csparpa/pyowm")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1pm8w6phr4m3xayndfndid366vhf1fpvdgjsp2zicxarmgc0pm53"))))
- (build-system python-build-system)
- (propagated-inputs (list python-geojson python-pysocks python-requests))
+ (base32
+ "1ha4pp96y3jk33qnyir5851cnj4dc06q6wqn1b0w54l3fsds28vi"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:test-flags #~(list "tests/unit")))
+ (native-inputs (list python-pytest))
+ (propagated-inputs
+ (list python-geojson-for-pyowm
+ python-pysocks
+ python-requests))
(home-page "https://github.com/csparpa/pyowm")
(synopsis "Python wrapper around OpenWeatherMap web APIs")
(description