aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-29 12:58:13 -0500
committerjgart <jgart@dismail.de>2024-08-20 19:09:14 -0500
commit2977733d439922744163b23d497122e732dfbb48 (patch)
tree9864be9d7b455200ba3ad46cb0ea9d09e6cb730b /gnu/packages/python-web.scm
parentd396824d477cabaf759fbe46bbf612f5acd5995c (diff)
downloadguix-2977733d439922744163b23d497122e732dfbb48.tar
guix-2977733d439922744163b23d497122e732dfbb48.tar.gz
gnu: Add python-httpauth.
* gnu/packages/python-web.scm (python-httpauth): New variable. Change-Id: I02ece90600961a634d30f34c301bd387e5aa23b7 Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94a0406ea7..5bc57fe0e5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -45,7 +45,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021 Pradana Aumars <paumars@courrier.dev>
;;; Copyright © 2021, 2022, 2024 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2021, 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2021, 2022, 2024 jgart <jgart@dismail.de>
;;; Copyright © 2021 Alice Brenon <alice.brenon@ens-lyon.fr>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
@@ -831,6 +831,24 @@ ASGI server.")
way around. It depends only on the Python standard library.")
(license license:asl2.0)))
+(define-public python-httpauth
+ (package
+ (name "python-httpauth")
+ (version "0.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "httpauth" version))
+ (sha256
+ (base32
+ "1m6rwvivg61l3h34hf6p6gkqmr69sb1c4k5ha379nxq0p8bfgahb"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/jonashaag/httpauth")
+ (synopsis "WSGI HTTP Digest Authentication middleware")
+ (description "@code{python-httpauth} is WSGI middleware that secures some/all
+routes using HTTP Digest Authentication.")
+ (license license:bsd-2)))
+
(define-public python-css-html-js-minify
(package
(name "python-css-html-js-minify")