aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 21:50:59 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:20 +0800
commit0e25cba87d7fa915b4e357e475759e10b953cac6 (patch)
tree69c08cf5bd4a8999c30f3faaa0ecb17589cab8a2 /gnu/packages/python-web.scm
parentbe3c0cf68e1a113b1ee5979b8354da2580db553e (diff)
downloadguix-0e25cba87d7fa915b4e357e475759e10b953cac6.tar
guix-0e25cba87d7fa915b4e357e475759e10b953cac6.tar.gz
gnu: python-uvicorn: Update to 0.23.2.
* gnu/packages/python-web.scm (python-uvicorn): Update to 0.23.2. [build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Adjust accordingly. [native-inputs]: Add PYTHON-A2WSGI and PYTHON-HATCHLING. [propagated-inputs]: Remove PYTHON-ASGIREF.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 16 insertions, 19 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index ca65ea162f..6aaa7504c4 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5784,7 +5784,7 @@ and fairly speedy.")
(define-public python-uvicorn
(package
(name "python-uvicorn")
- (version "0.17.6")
+ (version "0.23.2")
(source
(origin
;; PyPI tarball has no tests.
@@ -5794,23 +5794,21 @@ and fairly speedy.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0npwls02nhna2lyw2nksxij16l9agf12c9f42pvxb5yrpi9l16c8"))))
- (build-system python-build-system)
+ (base32 "1qa4cwifss9cnasfr0ffn76rvh7wcfjkl6nw99yz43rjmdpj3h7p"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-o" "asyncio_mode=auto"
- "-k"
- (string-append
- ;; These error or fail due to networking.
- "not test_keepalive "
- "and not test_bind_unix_socket_works_with_"
- "reload_or_workers "))))))))
- (native-inputs
- (list python-httpx-bootstrap
+ (list #:test-flags
+ #~(list "-o" "asyncio_mode=auto"
+ "-k"
+ (string-join
+ ;; These error or fail due to networking.
+ '("not test_keepalive"
+ "not test_bind_unix_socket_works_with_reload_or_workers")
+ " and "))))
+ (native-inputs
+ (list python-a2wsgi
+ python-hatchling
+ python-httpx-bootstrap
python-pytest
python-pytest-asyncio
python-pytest-mock
@@ -5818,8 +5816,7 @@ and fairly speedy.")
python-trustme
python-wsproto))
(propagated-inputs
- (list python-asgiref
- python-click
+ (list python-click
python-dotenv
python-h11
python-httptools