aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorMarco Baggio <marco.baggio@mdc-berlin.de>2024-04-29 14:17:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:15 +0200
commitd470a9aa543b8e9330b4aad4e2402aa50c357d42 (patch)
tree21e18e761134d5993964742cbb2291c7447783b2 /gnu/packages/python-science.scm
parent670dcc8e4c56413d646c034d0c382bd6977992eb (diff)
downloadguix-d470a9aa543b8e9330b4aad4e2402aa50c357d42.tar
guix-d470a9aa543b8e9330b4aad4e2402aa50c357d42.tar.gz
gnu: Add python-scs.
* gnu/packages/python-science.scm (python-scs): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net> Change-Id: I6c5ecdac4b558aab4b8ee396dff1dfc9cdec07f0
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 190dca5d06..26bc86d133 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1584,6 +1584,33 @@ Python's native complex data types is also supported.")
automated with the minimum of fuss and the least effort.")
(license license:expat)))
+(define-public python-scs
+ (package
+ (name "python-scs")
+ (version "3.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bodono/scs-python")
+ (commit "3.2.4")
+ (recursive? #true)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06wd8m3ri0gaddl7qq6243g25zjlnh3da915b73jnrfh7sg1nqsj"))))
+ (build-system pyproject-build-system)
+ (inputs (list meson-python openblas))
+ (propagated-inputs (list python-numpy python-scipy))
+ (native-inputs
+ (list pkg-config
+ python-meson-python
+ python-pytest))
+ (home-page "https://github.com/bodono/scs-python")
+ (synopsis "Splitting conic solver")
+ (description "This package provides a Python interface for the
+SCS (Splitting conic solver) library.")
+ (license license:expat)))
+
(define-public python-statannot
(package
(name "python-statannot")