aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-30 15:24:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commitadf54dea4e685fe00ab7f106ef264acad6e18cee (patch)
tree75a68d20bda5eeeed0718f74547d4345ac8cd05d /gnu/packages/python-science.scm
parent9953207f3ee28f5129e709db6c5afd76bf14afdb (diff)
downloadguix-adf54dea4e685fe00ab7f106ef264acad6e18cee.tar
guix-adf54dea4e685fe00ab7f106ef264acad6e18cee.tar.gz
gnu: python-pandas-stub: Update to 2.1.1.230928.
This is a follow-up to commit ff2d0ecfca87450c82df8d74666261b1c19cbe66. * gnu/packages/python-science.scm (python-pandas-stub): Update to 2.1.1.230928. Change-Id: I2e8ce18bd25399b467a6ff2a6fb846f8bb969e4c
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0769ab8e96..124a893dfc 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -963,9 +963,8 @@ doing practical, real world data analysis in Python.")
(package
(name "python-pandas-stubs")
;; The versioning follows that of Pandas and uses the date of the
- ;; python-pandas-stubs release. This is the latest version of
- ;; python-pandas-stubs for python-pandas 1.5.3.
- (version "1.5.3.230321")
+ ;; python-pandas-stubs release.
+ (version "2.1.1.230928")
(source
(origin
;; No tests in the PyPI tarball.
@@ -975,7 +974,7 @@ doing practical, real world data analysis in Python.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1blwlq5053pxnmx721zdd6v8njiybz4azribx2ygq33jcpmknda6"))))
+ (base32 "13b6wcwf9ybxf492w1l8qqf2bcgch21xds5r88pfkmrvqhxwfpyr"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -995,8 +994,7 @@ doing practical, real world data analysis in Python.")
(system "Xvfb &")
(setenv "DISPLAY" ":0")
;; xsel needs to write a log file.
- (setenv "HOME"
- (getcwd)))))))
+ (setenv "HOME" (getcwd)))))))
(propagated-inputs (list python-types-pytz))
;; Add python-fastparquet to native inputs once it has been packaged. Its
;; tests will be skipped for now.