aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-science.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-05-01 22:40:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-05-05 22:38:16 +0200
commit92259a5d4b3fa2fb752e926992f00dbfec08b1c0 (patch)
treee567f20a93bd30820c568fe78c79a8c9ce2f34dc /gnu/packages/python-science.scm
parent53b2fe29734c58c0cf4a5ef0ae51a595998d7fa3 (diff)
downloadguix-92259a5d4b3fa2fb752e926992f00dbfec08b1c0.tar
guix-92259a5d4b3fa2fb752e926992f00dbfec08b1c0.tar.gz
gnu: python-pandas-stubs: Update tests.
This is a follow-up to adding ORC support to pyarrow. * gnu/packages/python-science.scm (python-pandas-stubs)[arguments]: Disable more tests that are due to enabling ORC support to pyarrow. Change-Id: I8c3ca6afff8128792738251c85a1dba3dc3b0569
Diffstat (limited to 'gnu/packages/python-science.scm')
-rw-r--r--gnu/packages/python-science.scm18
1 files changed, 14 insertions, 4 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 547c94c3a6..2def569348 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1026,14 +1026,24 @@ doing practical, real world data analysis in Python.")
(list
#:test-flags #~(list "-k"
(string-append
- ;; The python-pyarrow package in Guix is not built
- ;; with ORC integration, causing these tests to
- ;; fail.
+ ;; The python-pyarrow package in Guix is built
+ ;; with ORC integration, but these tests fail with
+ ;; an abort in ORC because a timezone file is not
+ ;; in the expected location:
+ ;; https://github.com/apache/arrow/issues/40633
"not test_orc"
" and not test_orc_path"
" and not test_orc_buffer"
" and not test_orc_columns"
- " and not test_orc_bytes"))
+ " and not test_orc_bytes"
+ " and not test_all_read_without_lxml_dtype_backend"
+
+ ;; Apparently "numpy.bool_" is not the same as the
+ ;; expected "bool".
+ " and not test_timedelta_cmp"
+ " and not test_timedelta_cmp_rhs"
+ " and not test_timestamp_cmp"
+ " and not test_timestamp_eq_ne_rhs"))
#:phases '(modify-phases %standard-phases
(add-before 'check 'prepare-x
(lambda _