aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-11 17:54:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-11 20:41:16 +0200
commitee4d9a74b2d84af25ee7bd8d7e8e9358d2b466d4 (patch)
tree229aafe31009797458d5252c690e0668ded86dda /gnu/packages/python-check.scm
parentf3a23fed20ad7f4f8db434c811f3538ba1b58dd3 (diff)
downloadguix-ee4d9a74b2d84af25ee7bd8d7e8e9358d2b466d4.tar
guix-ee4d9a74b2d84af25ee7bd8d7e8e9358d2b466d4.tar.gz
Revert "gnu: Add python-pytest-enabler."
This reverts commit 0a8c46e89f095a9ec3632d43920ac3cce49f16d5. An older version of python-pytest-enabler already exists in (gnu packages check).
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm56
1 files changed, 0 insertions, 56 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2398843af5..f272a252fc 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2115,62 +2115,6 @@ reducing a number of combinations of variables into a lesser set that covers
most situations.")
(license license:expat)))
-(define-public python-pytest-enabler
- (package
- (name "python-pytest-enabler")
- (version "2.1.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-enabler" version))
- (sha256
- (base32
- "0m7m19829jwj1wqss73m8q1lpmkqhzkqp1xm4ahq0d7kjjghd4cb"))))
- (build-system pyproject-build-system)
- (arguments
- (list
- #:test-flags
- '(list "--ignore=_custom_build/backend.py"
- "-k" "not mypy-status")
- #:phases
- '(modify-phases %standard-phases
- ;; The build system insists on ignoring the existing environment and
- ;; running "pip install".
- (add-after 'unpack 'do-not-use-pip-install
- (lambda _
- (substitute* "pyproject.toml"
- (("^build-backend.*") "\
-build-backend = \"backend\"
-backend_path = [\"_custom_build\"]\n")
- (("requires = .*") "requires = []\n"))
- (mkdir-p "_custom_build")
- (with-output-to-file "_custom_build/backend.py"
- (lambda _
- (display "\
-from setuptools import build_meta as _orig
-from setuptools.build_meta import *
-def get_requires_for_build_wheel(config_settings=None):
- return []
-def get_requires_for_build_sdist(config_settings=None):
- return []
-")))
- (setenv "PYTHONPATH"
- (string-append (getcwd) "/_custom_build")))))))
- (propagated-inputs (list python-jaraco-context python-jaraco-functools
- python-toml))
- (native-inputs (list python-flake8
- python-pytest
- python-pytest-black
- python-pytest-checkdocs
- python-pytest-cov
- python-pytest-flake8
- python-pytest-mypy
- python-types-toml))
- (home-page "https://github.com/jaraco/pytest-enabler")
- (synopsis "Enable installed pytest plugins")
- (description "The enabler plugin allows configuration of plugins if
-present, but omits the settings if the plugin is not present.")
- (license license:expat)))
-
(define-public python-pytest-mp
(package
(name "python-pytest-mp")