aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-02 13:05:18 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:46 +0100
commit77c8bff0ea912c4d1173e7140b4bf1e46c549852 (patch)
treefb742c8a067ddaffcd93d5bddbd4e92f95f9c8df /gnu/packages/python-check.scm
parent66c1a004ac28c78faa05a92d610080eaf210d210 (diff)
downloadguix-77c8bff0ea912c4d1173e7140b4bf1e46c549852.tar
guix-77c8bff0ea912c4d1173e7140b4bf1e46c549852.tar.gz
gnu: python-pytest-openfiles: Simplify package.
* gnu/packages/python-check.scm (python-pytest-openfiles) [build-system]: Swap to pyproject-build-system. [arguments]: <#:phases>: Use default 'chck phase. Change-Id: I3bbbacd8694afdfee020f11d37f5c035bdad73f9
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index b6e401b443..74e833686f 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -847,15 +847,7 @@ access to test session metadata.")
(uri (pypi-uri "pytest_openfiles" version))
(sha256
(base32 "14x9f1l9a5ghf527i5qfcfa003mkrky1dhx2hfwq5nma9v1n0lgz"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"))))))
+ (build-system pyproject-build-system)
(native-inputs
(list python-setuptools-scm python-pytest))
(propagated-inputs