aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-04-28 11:25:01 +0200
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-05-05 09:14:30 +0200
commit5d38269aca735d2476ccf52770e18c1c3b77f6ff (patch)
tree9746ad3e7c858c294de11b673daf695c38b28f87 /gnu/packages/python-check.scm
parentd1e4803474de384b40064a86b690d276e0e0ba13 (diff)
downloadguix-5d38269aca735d2476ccf52770e18c1c3b77f6ff.tar
guix-5d38269aca735d2476ccf52770e18c1c3b77f6ff.tar.gz
gnu: python-atpublic: Update to 3.1.1.
* gnu/packages/python-check.scm (python-atpublic): Update to 3.1.1. [build-system]: Switch to pyproject-build-system. [arguments]: Remove #:phases, override build backend. [native-inputs]: Replace nose2 with pytest, add python-pdm-backend, python-sybil and python-pytest-cov.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index c42cd426b1..c4cf3c4bd4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1736,27 +1736,18 @@ Python software under test, when they make an HTTP query.")
(define-public python-atpublic
(package
(name "python-atpublic")
- (version "1.0")
+ (version "3.1.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "atpublic" version))
(sha256
(base32
- "0i3sbxkdlbb4560rrlmwwd5y4ps7k73lp4d8wnmd7ag9k426gjkx"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'enable-c-implementation
- (lambda _
- (setenv "ATPUBLIC_BUILD_EXTENSION" "yes")
- #t))
- (replace 'check
- (lambda _
- (invoke "python" "-m" "nose2" "-v"))))))
+ "060v2b5jfn7p99j09amxlb6w9ynwbq7fix31kl0caz0hs09fx61h"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:build-backend "pdm.backend"))
(native-inputs
- (list python-nose2))
+ (list python-pytest python-pdm-backend python-sybil python-pytest-cov))
(home-page "https://public.readthedocs.io/")
(synopsis "@code{@@public} decorator for populating @code{__all__}")
(description