aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-02-11 11:45:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-11 21:03:06 +0000
commit5ccae1ae44b6f2b3f8a687611d61194a14dc1e0f (patch)
treecca7e19113754b40d83d2071836e634bae3373ba /gnu/packages/python-check.scm
parentbcd9a40c4951fa2f86978df888c05e003c9f7cc0 (diff)
downloadguix-5ccae1ae44b6f2b3f8a687611d61194a14dc1e0f.tar
guix-5ccae1ae44b6f2b3f8a687611d61194a14dc1e0f.tar.gz
gnu: python-pyinstrument: Enable tests.
* gnu/packages/python-check.scm (python-pyinstrument) [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-greenlet. Change-Id: I1cd0c3e906fbbdc561e66bae9fe35333f61801cf
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 90f2f4c8ae..315ea74459 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -327,20 +327,28 @@ result documents that can be read by tools such as Jenkins or Bamboo.")
(uri (pypi-uri "pyinstrument" version))
(sha256
(base32 "1xnp1pjhcj1xl4dq20yzzj9599cmiyxb2azblsyjnl6qgr8yw0h0"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "-k" (string-append
+ ;; Disable some failing tests.
+ "not test_script_execution_details"
+ " and not test_path_execution_details"
+ " and not test_module_execution_details"
+ " and not test_program_passed_as_string_execution_details"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'build-extensions
+ (lambda _
+ (setenv "HOME" "/tmp")
+ (invoke "python" "setup.py" "build_ext" "--inplace"))))))
(native-inputs
(list python-flaky
+ python-greenlet
python-pytest
python-pytest-asyncio
python-pytest-trio))
- (arguments
- `(;; TODO: Get tests to work.
- #:tests? #f
- #:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
(home-page "https://github.com/joerick/pyinstrument")
(synopsis "Call stack profiler for Python")
(description