aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:12 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit596f3beeb78609c1bbc000dbc56be87229e5d840 (patch)
tree61150b3bb76b12b875e57920f5948d0204728ef0 /gnu/packages/python-check.scm
parent3a5c78b287ad80e05d09079abee23cf23b5af471 (diff)
downloadguix-596f3beeb78609c1bbc000dbc56be87229e5d840.tar
guix-596f3beeb78609c1bbc000dbc56be87229e5d840.tar.gz
gnu: python-pytest-mpl: Update to 0.16.1.
* gnu/packages/python-check.scm (python-pytest-mpl): Update to 0.16.1. [build-system]: Use pyproject-build-system. [arguments]<phases>: Simplify phases by removing redundant modification and use <test-flags> instead. [propagated-inputs]: Add python-jinja2, python-packaging. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d3848de95a..f272a252fc 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -831,24 +831,25 @@ framework and makes it easy to undo any monkey patching. The fixtures are:
(define-public python-pytest-mpl
(package
(name "python-pytest-mpl")
- (version "0.11")
+ (version "0.16.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-mpl" version))
(sha256
- (base32 "1km202c1s5kcn52fx0266p06qb34va3warcby594dh6vixxa9i96"))))
- (build-system python-build-system)
+ (base32 "0sa4229xkkah3fdg9wnqnvb9j13xsd3x1h5rwbsgb3sf2a0icmrd"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (list
+ #:test-flags #~(list "-m" "mpl_image_compare")))
(native-inputs
(list python-pytest))
(propagated-inputs
- (list python-matplotlib python-nose python-pillow))
+ (list python-jinja2
+ python-matplotlib
+ python-nose
+ python-packaging
+ python-pillow))
(home-page "https://github.com/matplotlib/pytest-mpl")
(synopsis "Pytest plugin to help with testing figures output from Matplotlib")
(description