aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:06 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit2f9173430f0b72c59313bc8f7943d305364bfe3a (patch)
treeee99467979010939c22c1ec52945cc238bb0e648 /gnu/packages/python-check.scm
parent735513e93e74b64ce680344c06c2190d6487130e (diff)
downloadguix-2f9173430f0b72c59313bc8f7943d305364bfe3a.tar
guix-2f9173430f0b72c59313bc8f7943d305364bfe3a.tar.gz
gnu: python-pytest-astropy: Simplify package.
* gnu/package/python-check.scm (python-pytest-astropy): Simplify package. [arguments]<phases>: Remove remove-requirement phase. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm11
1 files changed, 1 insertions, 10 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 3f2404c823..2c31116bd5 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -518,16 +518,7 @@ Astropy project, but is optimized for use with astropy-related projects.")
(sha256
(base32 "04g2rh261s3s6ym8mwi4iv2a6anbgwvwzcvkyilfck6yxrncdqw5"))))
(build-system python-build-system)
- (arguments
- `(#:tests? #f ; there are no tests
- #:phases
- (modify-phases %standard-phases
- ;; There is a bug somewhere that makes pytest-filter-subpackage appear
- ;; as version 0.0.0 to setup.py. Remove it from the requirements.
- (add-after 'unpack 'remove-requirement
- (lambda _
- (substitute* "setup.cfg"
- ((".*pytest-filter-subpackage.*") "")))))))
+ (arguments (list #:tests? #f)) ; there are no tests
(native-inputs
(list python-attrs python-pytest-mock python-setuptools-scm))
(propagated-inputs