aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:10 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit16e83296d7876a25c86c7a63f53a3181b81ad2dd (patch)
treeea57b078d5a3e6046c21fcb1e7cda009832d7d1e /gnu/packages/python-check.scm
parenta1baa54b8a8b4efa8ae01357ff21ad9cc0e50209 (diff)
downloadguix-16e83296d7876a25c86c7a63f53a3181b81ad2dd.tar
guix-16e83296d7876a25c86c7a63f53a3181b81ad2dd.tar.gz
gnu: python-pytest-remotedata: Update to 0.4.0.
* gnu/packages/python-check.scm (python-pytest-remotedata): Update to 0.4.0. [build-system]: Use pyproject-build-system. [arguments]<phases>: Simplify by removing not required phase modification and use <test-flags> instead. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Delete python-six, add python-packaging. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 9 insertions, 16 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2c31116bd5..f0211b604b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -735,30 +735,23 @@ were inadvertently left open at the end of a unit test.")
(define-public python-pytest-remotedata
(package
(name "python-pytest-remotedata")
- (version "0.3.2")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-remotedata" version))
(sha256
- (base32 "1h6g6shib6z07azf12rnsa053470ggbd7hy3bnbw8nf3nza5h372"))))
- (build-system python-build-system)
+ (base32 "1j5106j331cfdyfcwzrbs3yby84mq1b0kddfysq12z2dwdcca8dy"))))
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs #:allow-other-keys)
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv" "-k"
- (string-append
- ;; These tests require internet access. Disable them.
- "not test_default_behavior"
- " and not test_strict_with_decorator")))))))
+ (list
+ #:test-flags #~(list "-k" (string-append
+ "not test_default_behavior"
+ " and not test_strict_with_decorator"))))
(native-inputs
- (list python-pytest))
+ (list python-pytest python-setuptools-scm))
(propagated-inputs
- (list python-six))
+ (list python-packaging))
(home-page "https://github.com/astropy/pytest-remotedata")
(synopsis "Pytest plugin for controlling remote data access")
(description