aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-05-16 11:22:56 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:03 +0200
commita0d74866abddd1f90cb073d7a59acd74f9df0063 (patch)
treebde87db6d6258934e51177107f3f9496fe878d8a /gnu/packages/python-build.scm
parentb6ea2c48f69ffd1b79f25580ce45c815c12de57a (diff)
downloadguix-a0d74866abddd1f90cb073d7a59acd74f9df0063.tar
guix-a0d74866abddd1f90cb073d7a59acd74f9df0063.tar.gz
gnu: python-pip: Ungraft.
* gnu/packages/python-build.scm (python-pip): Ungraft and apply source snippet directly. (python-pip/fixed): Remove variable. Change-Id: I4913e8f87f5934bffec9d58ad86b97f8ca16ba32
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm43
1 files changed, 18 insertions, 25 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 72da369208..aeb088e75a 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -284,36 +284,20 @@ Included are implementations of:
(package
(name "python-pip")
(version "23.1")
- (replacement python-pip/fixed)
(source
(origin
(method url-fetch)
(uri (pypi-uri "pip" version))
(sha256
(base32
- "0jnk639v9h7ghslm4jnlic6rj3v29nygflx1hgxxndg5gs4kk1a0"))))
- (build-system python-build-system)
- (arguments
- '(#:tests? #f)) ; there are no tests in the pypi archive.
- (home-page "https://pip.pypa.io/")
- (synopsis "Package manager for Python software")
- (description
- "Pip is a package manager for Python software, that finds packages on the
-Python Package Index (PyPI).")
- (license license:expat)))
-
-(define python-pip/fixed
- (package
- (inherit python-pip)
- (source (origin
- (inherit (package-source python-pip))
- (snippet
- #~(begin
- (delete-file "src/pip/_vendor/certifi/cacert.pem")
- (delete-file "src/pip/_vendor/certifi/core.py")
- (with-output-to-file "src/pip/_vendor/certifi/core.py"
- (lambda _
- (display "\"\"\"
+ "0jnk639v9h7ghslm4jnlic6rj3v29nygflx1hgxxndg5gs4kk1a0"))
+ (snippet
+ #~(begin
+ (delete-file "src/pip/_vendor/certifi/cacert.pem")
+ (delete-file "src/pip/_vendor/certifi/core.py")
+ (with-output-to-file "src/pip/_vendor/certifi/core.py"
+ (lambda _
+ (display "\"\"\"
certifi.py
~~~~~~~~~~
This file is a Guix-specific version of core.py.
@@ -335,7 +319,16 @@ def where() -> str:
def contents() -> str:
with open(where(), \"r\", encoding=\"ascii\") as data:
- return data.read()")))))))))
+ return data.read()")))))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; there are no tests in the pypi archive.
+ (home-page "https://pip.pypa.io/")
+ (synopsis "Package manager for Python software")
+ (description
+ "Pip is a package manager for Python software, that finds packages on the
+Python Package Index (PyPI).")
+ (license license:expat)))
(define-public python-setuptools
(package