aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-16 00:33:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:14 -0400
commit2bf851e4b83f91236657982b2d334a1db9d027ec (patch)
tree4e3ff67e5b2e9b275a262da9f785ab4475bbfa4e /gnu/packages/python-build.scm
parent545b9548d590edf3cbf357524abc964762a348b8 (diff)
downloadguix-2bf851e4b83f91236657982b2d334a1db9d027ec.tar
guix-2bf851e4b83f91236657982b2d334a1db9d027ec.tar.gz
gnu: Add python-hatch-vcs.
* gnu/packages/python-build.scm (python-hatch-vcs): New variable.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index f2724ed2fa..0e3d3675a4 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -675,3 +675,22 @@ has features such as:
@item Responsive CLI, ~2-3x faster than equivalent tools.
@end itemize")
(license license:expat)))
+
+(define-public python-hatch-vcs
+ (package
+ (name "python-hatch-vcs")
+ (version "0.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "hatch_vcs" version))
+ (sha256
+ (base32
+ "1viz2mdfxfqpsd5f30410q6smj90qfxihvy9idzwd0p4ziy11iff"))))
+ (arguments (list #:tests? #f)) ;avoid extra test dependencies
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-hatchling python-setuptools-scm))
+ (home-page "https://github.com/ofek/hatch-vcs")
+ (synopsis "Hatch plugin for versioning with your preferred VCS")
+ (description "This package is a plugin for Hatch that uses your preferred
+version control system (like Git) to determine project versions.")
+ (license license:expat)))